Spacemesh-浏览器

Nosana创建节点的疑难解答指南 常见问题

21次阅读
没有评论

错误消息

英伟达

nvidia-smi:找不到命令

这意味着您没有安装 NVIDIA 驱动程序。要安装它们,请从 NVIDIA 网站下载并安装正确的驱动程序:https://www.nvidia.com/download/index.aspx在新窗口中打开

错误:设置 CDI 设备:无法解析的 CDI 设备 nvidia.com/gpu=all

这意味着您没有正确安装和配置 Nvidia Container Toolkit:

在此 WSL 2 发行版中找不到命令“docker”。

溶液

确保您有Docker 桌面在新窗口中打开已安装并且它正在运行。如果仍有此错误消息,请检查 Docker Desktop 是否使用 WSL2 后端(而不是 Hyper-V)。按照本指南打开 Docker Desktop 的 WSL2 后端:https://docs.docker.com/desktop/wsl/在新窗口中打开.

此外,请检查命令提示符或 Powershell,以确保已安装 WSL 版本 2:

wsl -l -v

此外,请确保 Ubuntu 22.04 发行版是默认的 WSL 发行版。在默认 WSL 分发上启用了 Docker-WSL 集成。若要更改默认 WSL 发行版,请运行:

wsl --set-default <distro name>

错误:无法连接到 Podman

当您在 Docker Desktop 中看到此错误时,请转到 Docker Desktop 到 -> Settings -> Docker engine,请在第一个括号后的某处添加此行,如下所示:"bip":"192.168.200.1/24",

{
  "bip":"192.168.200.1/24",
}

然后单击 appy 并重新启动 Docker。

错误:容器创建失败(没有来自 conmon 的日志):conmon bytes “”: readObjectStart: expect { or n, but found , error found in #0 byte of …||…, 更大的背景 …||…

此错误是由最新版本的已知问题,降级以解决此问题引起的,如下所示:conmonconmon

wget https://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable/xUbuntu_22.04/amd64/conmon_2.1.2~0_amd64.deb -O /tmp/conmon_2.1.2.deb
sudo apt install /tmp/conmon_2.1.2.deb

然后,您可以重新运行 podmon 命令

podman run --rm --device nvidia.com/gpu=all --security-opt=label=disable ubuntu nvidia-smi -L

正文完
 0
pexpay
版权声明:本站原创文章,由 pexpay 于2024-07-06发表,共计1259字。
转载说明:除特殊说明外本站文章皆由CC-4.0协议发布,转载请注明出处。
评论(没有评论)